Error message

  • Warning: Illegal string offset 'field' in DatabaseCondition->__clone() (line 1901 of /home1/rholroyd/drupal/drupal-7.12/includes/database/query.inc).
  • Warning: Illegal string offset 'field' in DatabaseCondition->__clone() (line 1901 of /home1/rholroyd/drupal/drupal-7.12/includes/database/query.inc).
  • Warning: Illegal string offset 'field' in DatabaseCondition->__clone() (line 1901 of /home1/rholroyd/drupal/drupal-7.12/includes/database/query.inc).
  • Warning: Illegal string offset 'field' in DatabaseCondition->__clone() (line 1901 of /home1/rholroyd/drupal/drupal-7.12/includes/database/query.inc).
  • Warning: Illegal string offset 'field' in DatabaseCondition->__clone() (line 1901 of /home1/rholroyd/drupal/drupal-7.12/includes/database/query.inc).
  • Warning: Illegal string offset 'field' in DatabaseCondition->__clone() (line 1901 of /home1/rholroyd/drupal/drupal-7.12/includes/database/query.inc).
  • Warning: Illegal string offset 'field' in DatabaseCondition->__clone() (line 1901 of /home1/rholroyd/drupal/drupal-7.12/includes/database/query.inc).
  • Warning: Illegal string offset 'field' in DatabaseCondition->__clone() (line 1901 of /home1/rholroyd/drupal/drupal-7.12/includes/database/query.inc).
  • Warning: Illegal string offset 'field' in DatabaseCondition->__clone() (line 1901 of /home1/rholroyd/drupal/drupal-7.12/includes/database/query.inc).
  • Warning: Illegal string offset 'field' in DatabaseCondition->__clone() (line 1901 of /home1/rholroyd/drupal/drupal-7.12/includes/database/query.inc).
  • Warning: Illegal string offset 'field' in DatabaseCondition->__clone() (line 1901 of /home1/rholroyd/drupal/drupal-7.12/includes/database/query.inc).
  • Warning: Illegal string offset 'field' in DatabaseCondition->__clone() (line 1901 of /home1/rholroyd/drupal/drupal-7.12/includes/database/query.inc).
  • Warning: Illegal string offset 'field' in DatabaseCondition->__clone() (line 1901 of /home1/rholroyd/drupal/drupal-7.12/includes/database/query.inc).
  • Warning: Illegal string offset 'field' in DatabaseCondition->__clone() (line 1901 of /home1/rholroyd/drupal/drupal-7.12/includes/database/query.inc).
  • Warning: Illegal string offset 'field' in DatabaseCondition->__clone() (line 1901 of /home1/rholroyd/drupal/drupal-7.12/includes/database/query.inc).
  • Warning: Illegal string offset 'field' in DatabaseCondition->__clone() (line 1901 of /home1/rholroyd/drupal/drupal-7.12/includes/database/query.inc).
  • Warning: Illegal string offset 'field' in DatabaseCondition->__clone() (line 1901 of /home1/rholroyd/drupal/drupal-7.12/includes/database/query.inc).
  • Warning: Illegal string offset 'field' in DatabaseCondition->__clone() (line 1901 of /home1/rholroyd/drupal/drupal-7.12/includes/database/query.inc).

February 2011

Tag clouds in Drupal 7 using Tagadelic

Drupal has a nice module for generating Tag Clouds from the Taxanomy system. Unfortunately, a version for Drupal 7 is not available yet through drupal.org. There is a compatible version available on GitHub that can be installed easily and seems to be working so far without any problems.

Here's how to get Tagadelic for Drupal 7

Finding large files from the command line

To find the largest files using the command line, you could use the following:  

[geshifilter-pre class="brush:bash;"] $ du -a | sort -rn | head[/geshifilter-pre]

 

Checking which version of Ubuntu Server is installed

You can find out which version of Ubuntu you currently have installed with the following command:

[geshifilter-pre class="brush:bash;"] $ lsb_release -a[/geshifilter-pre]

 

Webmin reports package updates. Really?

Just had a problem with Webmin reporting that packages were updated and need to be installed. When going through the install process it seemed that there were some packages still to be installed. Going back through the update process shows no packages updated...

After a while of this happening, new packages available then install missing some I found that some security patches were being missed by Webmin. Doing an update from command line seems to have fixed the problem:

[geshifilter-pre class="brush:plain;"] $ sudo apt-get upgrade[/geshifilter-pre]